OSPF IPv6 Lab Open Shortest Path First

Lab Diagram

2001:1:\64

2001:3:\64

2001:2:\64

2001:f:\64

2001:a:\64

2001:b:\64

Lab Objectives

  • Cable a network in accordance with the diagram given
  • Configure the hostname and interface IP addresses, or paste the initial configuration onto all devices
  • Ensure that R1's router-id will always be set to 1.1.1.1, without he use of the router-id command
  • Change the router-id of R2 to 2.2.2.2 without using the router-id command, and ensure that it will always be set to this on start up
  • Configure R3's router-id (3.3.3.3) using a loopback interface
  • Enable OSPF on all interfaces
  • NOTE: R1's Fa0/0 interface should not be a part of the OSPF process at all
  • Ensure that a malicious user cannot form an OSPF adjacency on the R2 and R3 LANs
  • Configure a default route on R1 to the ISP router (2001:F::2)
  • By only changing the configuration on R1, ensure that all other routers will treat R1 as their gateway of last resort

Initial Configuration (Already applied to devices in console)

R1 R2 R3
!Configuration generated by CCNAPractice.com 
!
!
hostname R1
!
ipv6 unicast-routing
!
!
!
interface Serial0/0
 ipv6 address 2001:1::1/64
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ipv6 address 2001:3::1/64
 no shutdown
!
interface FastEthernet0/0
 ipv6 address 2001:f::1/64
 no shutdown
!
!
!
!
!
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R2
!
ipv6 unicast-routing
!
!
!
interface Serial0/0
 ipv6 address 2001:2::1/64
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ipv6 address 2001:1::2/64
 no shutdown
!
interface FastEthernet0/0
 ipv6 address 2001:a::1/64
 no shutdown
!
!
!
!
!
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R3
!
ipv6 unicast-routing
!
!
!
interface Serial0/0
 ipv6 address 2001:3::2/64
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ipv6 address 2001:2::2/64
 no shutdown
!
interface FastEthernet0/0
 ipv6 address 2001:b::1/64
 no shutdown
!
!
!
!
!
!
line con 0
!
end

Final Configuration

R1 R2 R3
!Configuration generated by CCNAPractice.com 
!
!
hostname R1
!
ipv6 unicast-routing
!
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 no shutdown
!
interface Serial0/0
 ipv6 address 2001:1::1/64
 ipv6 ospf 1 area 0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ipv6 address 2001:3::1/64
 ipv6 ospf 1 area 0
 no shutdown
!
interface FastEthernet0/0
 ipv6 address 2001:f::1/64
 no shutdown
!
!
ipv6 route ::/0 2001:f::2
!
!
!
!
ipv6 router ospf 1
 default-information originate
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R2
!
ipv6 unicast-routing
!
!
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
 no shutdown
!
interface Serial0/0
 ipv6 address 2001:2::1/64
 ipv6 ospf 1 area 0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ipv6 address 2001:1::2/64
 ipv6 ospf 1 area 0
 no shutdown
!
interface FastEthernet0/0
 ipv6 address 2001:a::1/64
 ipv6 ospf 1 area 0
 no shutdown
!
!
!
!
!
!
ipv6 router ospf 1
 passive-interface FastEthernet0/0
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R3
!
ipv6 unicast-routing
!
!
!
interface Loopback1
 ip address 3.3.3.3 255.255.255.255
 no shutdown
!
interface Serial0/0
 ipv6 address 2001:3::2/64
 ipv6 ospf 1 area 0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ipv6 address 2001:2::2/64
 ipv6 ospf 1 area 0
 no shutdown
!
interface FastEthernet0/0
 ipv6 address 2001:b::1/64
 ipv6 ospf 1 area 0
 no shutdown
!
!
!
!
!
!
ipv6 router ospf 1
 passive-interface FastEthernet0/0
!
line con 0
!
end


R1#
R2#
R3#

Comments